summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-03-20 00:30:55 +0000
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-03-20 00:30:55 +0000
commite87c7e045dd5a8fe64a6f70d3195b174513deed2 (patch)
tree52fae196f51950dc566c6f1ba0ce61b5e3d8d7ad /configure.ac
parent3ca4981e58cb1c95e9959c1d49bf96aee294b5f7 (diff)
downloadxine-lib-e87c7e045dd5a8fe64a6f70d3195b174513deed2.tar.gz
xine-lib-e87c7e045dd5a8fe64a6f70d3195b174513deed2.tar.bz2
The AC_C_ATTRIBUTE_ALIGNED macro is broken, it always reports maximum aligned available as 64 even on Darwin where the maximum is 16, as it does not use -Werror, and the wrong alignment is considered only a warning. Rewrite it as CC_ATTRIBUTE_ALIGNED (in attributes.m4, where other similar macros are located). Also reverse the order of the checks, so that the highest version is tried first; this way you can avoid five compile tests on systems where 64 is the highest alignment available.
CVS patchset: 8726 CVS date: 2007/03/20 00:30:55
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 01b4ea56e..c14af373d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2212,10 +2212,11 @@ dnl dummy
ASFLAGS="$ASFLAGS"
AC_SUBST(ASFLAGS)
-dnl check for __attribute__ ((aligned ()))
-dnl WARNING! Do not move this check behind the $(MULTIPASS_CFLAGS)!
-dnl (the alignment test macro does not like variables in the CFLAGS)
-AC_C_ATTRIBUTE_ALIGNED
+dnl ---------------------------------------------
+dnl Check for some __attribute__ support needed
+dnl ---------------------------------------------
+
+CC_ATTRIBUTE_ALIGNED
CC_ATTRIBUTE_VISIBILITY([
CC_FLAG_VISIBILITY([