summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-01-21 01:44:33 +0000
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-01-21 01:44:33 +0000
commited8842bea5d4452e5aa011804353f7c04d13f48e (patch)
treea4540e48bb7a4a752a33783a0ecfe2d235e780e8 /configure.ac
parent9a085abcbd7842aaede9e5aba9587cb9d7f38005 (diff)
downloadxine-lib-ed8842bea5d4452e5aa011804353f7c04d13f48e.tar.gz
xine-lib-ed8842bea5d4452e5aa011804353f7c04d13f48e.tar.bz2
Use docdir and htmldir as basedir to install the documentation into; these are defined by default by autoconf 2.61, so I've added code to define them when they are missing.
CVS patchset: 8536 CVS date: 2007/01/21 01:44:33
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 22 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a4a6e8348..41155d370 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2345,6 +2345,26 @@ AM_CONDITIONAL(HAVE_ARMV4L, test "x$enable_armv4l" = "xyes")
dnl ---------------------------------------------
+dnl Use features of autoconf 2.61, but stay compatible
+dnl with older versions.
+dnl ---------------------------------------------
+
+if test "x$datarootdir" = "x"; then
+ datarootdir='${datadir}'
+ AC_SUBST(datarootdir)
+fi
+
+if test "x$docdir" = "x"; then
+ docdir='${datarootdir}/doc/${PACKAGE}'
+ AC_SUBST(docdir)
+fi
+
+if test "x$htmldir" = "x"; then
+ htmldir='${docdir}'
+ AC_SUBST(htmldir)
+fi
+
+dnl ---------------------------------------------
dnl XINE_ROOTDIR does not work if architecture independent files are
dnl installed to another place than architecture dependent files !!!
dnl ---------------------------------------------
@@ -2418,12 +2438,12 @@ AC_SUBST(XINE_FONTDIR)
AC_SUBST(XINE_LOCALEDIR)
dnl Where aclocal m4 files should be installed
-XINE_ACFLAGS="-I `makeexpand "${datarootdir:-${datadir}}/aclocal"`"
+XINE_ACFLAGS="-I `makeexpand "${datarootdir}/aclocal"`"
AC_DEFINE_UNQUOTED(XINE_ACFLAGS, "$XINE_ACFLAGS", [Path where aclocal m4 files will be.])
AC_SUBST(XINE_ACFLAGS)
dnl Where architecture independent data (e.g. logo) will/should be installed
-XINE_DATADIR="`makeexpand "${datarootdir:-${datadir}}/xine"`"
+XINE_DATADIR="`makeexpand "${datarootdir}/xine"`"
AC_SUBST(XINE_DATADIR)
dnl Where scripts will/should be installed.