summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Messier <mmessier@grapetv.org>2007-05-04 21:55:20 -0400
committerMatt Messier <mmessier@grapetv.org>2007-05-04 21:55:20 -0400
commitf1d5c1fc6c4c79bdc8969b94cf0ca08d3dbd7735 (patch)
tree9d176ab2d4ec713b663aa8a317f32f7f596e3284 /configure.ac
parentb5de3be503bc9fac73ffbcaf6ce92970195c122f (diff)
downloadxine-lib-f1d5c1fc6c4c79bdc8969b94cf0ca08d3dbd7735.tar.gz
xine-lib-f1d5c1fc6c4c79bdc8969b94cf0ca08d3dbd7735.tar.bz2
More build cleanups
-- Pull AC_PROG_OBJC and AC_PROG_OBJCPP from autoconf 2.61, but use the local versions only if they're not defined by the version of autoconf in use. -- Always call AC_PROG_OBJC since there's no harm in doing so. It'll fail most of the time, but it's cleaner than adding yet another $host_os check -- Remove -DCONFIG_DARWIN from CPPFLAGS since it was added specifically for ffmpeg when ffmpeg was built using xine's built infrastructure rather than its own. It's now defined properly where its needed elsewhere. -- Set host_or_hostalias early rather than later in the middle of xv checking since a bunch of other stuff depends on it too.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 15 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 209fcf784..a32d61eb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -97,38 +97,34 @@ fi
AM_CONDITIONAL([PROFILING_BUILD], [test x"$enable_profiling" != x"no"])
-dnl ---------------------------------------------
-dnl Made possible to build for another arch.
-dnl ---------------------------------------------
+dnl ----------------------------------------------
+dnl Cross compilation, Mac OS X Universal Binaries
+dnl ----------------------------------------------
-AC_CANONICAL_HOST
AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
-test "$host" == "$build" && check_athlon=yes
-
-
+dnl check for Mac OS X universal binary support early, because certain flags
+dnl must be set prior to looking for cc/libtool, etc.
MACOSX_UNIVERSAL_BINARIES
+dnl Check to see if $host is empty. If it is, try $host_alias instead.
+dnl If $host is empty, it's because the user has run ./configure with a host
+dnl parameter unknown to config.sub. This used to be set in xv handling, but
+dnl it's also used in a bunch of other places unrelated to Xwindows support,
+dnl so if X is disabled, other things could go badly.
+host_or_hostalias="$host"
+test x"$host_or_hostalias" = x"" && host_or_hostalias="$host_alias"
+
dnl ---------------------------------------------
dnl Check for programs.
dnl ---------------------------------------------
AC_PROG_CC
+AC_PROG_OBJC
AM_PROG_AS
-case "$host_os" in
- *darwin*)
- m4_ifdef([AC_PROG_OBJC],
- [AC_PROG_OBJC],
- [AC_CHECK_TOOL([OBJC], [gcc])
- AC_SUBST([OBJC])
- AC_SUBST([OBJCFLAGS])
- ])
- CPPFLAGS="$CPPFLAGS -DCONFIG_DARWIN"
- ;;
-esac
-
AC_GNU_SOURCE
dnl Save CFLAGS, AC_ISC_POSIX set some unwanted default CFLAGS
saved_CFLAGS="$CFLAGS"