summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDarren Salt <linux@youmustbejoking.demon.co.uk>2006-07-09 13:37:55 +0000
committerDarren Salt <linux@youmustbejoking.demon.co.uk>2006-07-09 13:37:55 +0000
commit5fbef4ec4950d710476b22880eae8d38437d4ada (patch)
tree68faba68aa664de402aca020e43653528306b0c1 /debian/rules
parent900502c6f185898f120a2117e7c4f62460b77bfe (diff)
downloadxine-lib-1.1.2.tar.gz
xine-lib-1.1.2.tar.bz2
DEB_BUILD_OPTIONS=noauto to run configure instead of autogen.sh.xine-lib-1_1_2-release1.1.2
CVS patchset: 8099 CVS date: 2006/07/09 13:37:55
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 3a5af27ef..889a909db 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,6 +30,7 @@ ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_TARGET := install-debug
BUILD_TARGET := debug
endif
+# note also "noauto" to inhibit running of autogen.sh
DEB_BUILD_GNU_OPTION :=
# the "optimize" flag disables compatibility hacks
@@ -60,12 +61,16 @@ CONFIGURE_FLAGS := --prefix=/usr \
$(DEB_BUILD_GNU_OPTION) \
CFLAGS="$(CFLAGS)"
-configure: configure-stamp
+configure: configure-stamp $(AUTOGEN)
configure-stamp:
dh_testdir
+ifeq (,$(findstring noauto,$(DEB_BUILD_OPTIONS))
# let's run autohell on the buildds!
chmod +x ./autogen.sh
./autogen.sh $(CONFIGURE_FLAGS)
+else
+ ./configure $(CONFIGURE_FLAGS)
+endif
touch configure-stamp
build: configure-stamp build-stamp