summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-04-04 23:53:39 +0200
committerDiego 'Flameeyes' Pettenò <flameeyes@gmail.com>2007-04-04 23:53:39 +0200
commitca897ff0f84cdc7fc83449d1d06dcc9528edbb97 (patch)
tree313c6245e23b257a05f220c65c6cdf2d474323be /debian
parent60a408c3446733dc752979c1eab579c25a4a4897 (diff)
parentf5dc5087a79d813259a674bd96ba4dea43fb254c (diff)
downloadxine-lib-ca897ff0f84cdc7fc83449d1d06dcc9528edbb97.tar.gz
xine-lib-ca897ff0f84cdc7fc83449d1d06dcc9528edbb97.tar.bz2
Merge with main repository.
--HG-- rename : src/libffmpeg/dvaudio_decoder.c => src/libffmpeg/ff_dvaudio_decoder.c rename : src/libffmpeg/video_decoder.c => src/libffmpeg/ff_video_decoder.c rename : src/libffmpeg/xine_decoder.h => src/libffmpeg/ffmpeg_decoder.h rename : src/libffmpeg/xine_encoder.c => src/libffmpeg/ffmpeg_encoder.c
Diffstat (limited to 'debian')
-rw-r--r--debian/reportbug.presubj46
-rwxr-xr-xdebian/rules5
2 files changed, 47 insertions, 4 deletions
diff --git a/debian/reportbug.presubj b/debian/reportbug.presubj
new file mode 100644
index 000000000..229cd9d74
--- /dev/null
+++ b/debian/reportbug.presubj
@@ -0,0 +1,46 @@
+Reporting Bugs on libxine - general remarks
+===========================================
+
+As you can see on http://bugs.debian.org/src:xine-lib, the list of
+bugs against xine is rather long. Please help the maintainer by
+ensuring that your bugreport contains all pieces of infromation to
+reproduce and check if the bug has been fixed.
+
+Reporting bugs for unsupported file formats
+===========================================
+
+If you report a bug that a specific file cannot be played, please make
+sure that you include a link to the file so the maintainers can try
+them. If you cannot (easily) point to that file, please check
+http://samples.mplayerhq.hu/ if you find a similar file with the same
+problem. In any case, please start xine with the parameter
+--bug-report. (If you are using gxine, please install the package
+xine-ui instead. If you can only reproduce the bug with gxine but not
+with xine-ui, then file the bug against gxine)
+
+Report bugs for xine crashes
+============================
+
+If you report a bug that applications linked against libxine1
+(xine-ui, gxine, amarok, totem, etc) segfault, please install the
+packages 'xine-ui' and 'libxine1-dbg', and try to reproduce it with
+this command:
+
+> ulimit -c unlimited ; /usr/bin/xine --bug-report <mrl>
+
+If you can reproduce the bug, then run gdb to get a backtrace:
+
+> gdb /usr/bin/xine core.*
+
+At the gdb prompt, please issue these commands:
+
+# backtrace
+# thread apply all backtrace full
+# quit
+
+Make sure to attach both files BUG-REPORT.TXT and the resulting
+backtrace from gdb. Both are necessary to understand where and how the
+segfault occured.
+
+Thanks for your collaboration.
+
diff --git a/debian/rules b/debian/rules
index ef1347e49..8e4ca67fe 100755
--- a/debian/rules
+++ b/debian/rules
@@ -62,13 +62,10 @@ endif
CONFIGURE_FLAGS := --prefix=/usr \
--mandir=\$${prefix}/share/man \
--with-external-libmad \
- --with-external-ffmpeg \
--with-external-a52dec \
--with-external-libdts \
--disable-cacatest \
$(DEB_BUILD_CONFIG_OPTIONS) \
- FFMPEG_CFLAGS="`pkg-config --cflags libavcodec`" \
- FFMPEG_LIBS="`pkg-config --libs libavcodec`" \
CFLAGS="$(CFLAGS)"
configure: configure-stamp
@@ -126,7 +123,7 @@ binary-arch: build install
mkdir -p debian/tmp/usr/share/bug/libxine${major}/
cp debian/reportbug.presubj debian/tmp/usr/share/bug/libxine${major}/presubj
# ugly hack, documentation should never have been in /u/s/d/xine/...
- mv debian/tmp/usr/share/doc/xine debian/tmp/usr/share/doc/libxine${major}
+ mv debian/tmp/usr/share/doc/xine-lib debian/tmp/usr/share/doc/libxine${major}
# build libxine${major} package by moving files from libxine-dev
dh_install --autodest --sourcedir=debian/tmp --list-missing
dh_installdocs