summaryrefslogtreecommitdiff
path: root/doc/hackersguide/Makefile.am
diff options
context:
space:
mode:
authorMichael Roitzsch <mroi@users.sourceforge.net>2003-10-12 19:06:43 +0000
committerMichael Roitzsch <mroi@users.sourceforge.net>2003-10-12 19:06:43 +0000
commit60239a297dd0e7a6454dbd15de9d0186dea93c14 (patch)
tree631575dda5455ec4b4e0e7695dad2b41a0bbfd75 /doc/hackersguide/Makefile.am
parent102661e8630883383e0a0c1d2d31765cce1ebc84 (diff)
downloadxine-lib-60239a297dd0e7a6454dbd15de9d0186dea93c14.tar.gz
xine-lib-60239a297dd0e7a6454dbd15de9d0186dea93c14.tar.bz2
updated hackersguide:
* added some small pieces * incorporated some former READMEs and Mike's fabulous demuxer and decoder doc * splitted into multiple files * made new drawings (hopefully I am not the only one to understand them) * Makefile support for building a HTML version which is now installed in the user's doc directory CVS patchset: 5494 CVS date: 2003/10/12 19:06:43
Diffstat (limited to 'doc/hackersguide/Makefile.am')
-rw-r--r--doc/hackersguide/Makefile.am40
1 files changed, 39 insertions, 1 deletions
diff --git a/doc/hackersguide/Makefile.am b/doc/hackersguide/Makefile.am
index c8974d51b..8e7303733 100644
--- a/doc/hackersguide/Makefile.am
+++ b/doc/hackersguide/Makefile.am
@@ -1,5 +1,43 @@
include $(top_srcdir)/misc/Makefile.common
-EXTRA_DIST = README intro.sgml hackersguide.sgml architecture.fig overlays.fig
+hackersguide_sgml = hackersguide.sgml \
+ intro.sgml \
+ library.sgml \
+ overview.sgml \
+ internals.sgml \
+ stream.sgml \
+ output.sgml
+
+EXTRA_DIST = README $(hackersguide_sgml) architecture.fig library.fig overlays.fig
+docs_DOCS = hackersguide.html architecture.png library.png overlays.png
docdir = $(prefix)/share/doc/xine/hackersguide
+
+install-data-local:
+ @documentations='$(docs_DOCS)'; \
+ for doc in $$documentations; do \
+ destdir=$(DESTDIR)$(docdir); \
+ name=`echo $$doc` \
+ dir=$$destdir; \
+ $(mkinstalldirs) $$dir; \
+ $(INSTALL_DATA) $$doc $$dir/$$name; \
+ echo "installing $$doc as $$dir/$$name"; \
+ done
+
+uninstall-local:
+ @documentations='$(docs_DOCS)'; \
+ for doc in $$documentations; do \
+ destdir=$(DESTDIR)$(docdir); \
+ name=`echo $$doc` \
+ dir=$$destdir; \
+ rm -f $$dir/$$name; \
+ echo "removing $$dir/$$name" ; \
+ done
+
+docs: $(docs_DOCS)
+
+hackersguide.html: $(hackersguide_sgml)
+ sgmltools -b onehtml hackersguide.sgml
+
+%.png: %.fig
+ fig2dev -L png -S 4 $< $@