summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules1
-rwxr-xr-xdebian/shlibdeps.sh17
4 files changed, 33 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index bff09e1a6..1b401124b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+xine-lib (0.9.2-3) unstable; urgency=high
+
+ * removed build-dependancy on libasound (useful on i386 only)
+ * allow for architectures building only some of the plugins
+ * added build-dependancy on ogg and vorbis libraries
+
+ -- Siggi Langauf <siggi@debian.org> Sat, 20 Oct 2001 17:58:53 +0200
+
+xine-lib (0.9.2-2) unstable; urgency=high
+
+ * added permission workaround for shlibdeps.sh (closes: #115881)
+
+ -- Siggi Langauf <siggi@debian.org> Wed, 17 Oct 2001 00:41:51 +0200
+
xine-lib (0.9.2-1) unstable; urgency=high
* now building alsa09 plugin (instead of alsa05, as you can't have
diff --git a/debian/control b/debian/control
index 93317ca75..4be3f0147 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: xine-lib
Section: libs
Priority: optional
Maintainer: Siggi Langauf <siggi@debian.org>
-Build-Depends: debhelper (>> 2.0.0), aalib1-dev (>= 1.4p5-2), xlibs-dev (>> 4.1), libesd0-dev, libz-dev, libarts-dev (>=4:2.2.0-final-3), libasound2-dev, liblircclient-dev
+Build-Depends: debhelper (>> 2.0.0), aalib1-dev (>= 1.4p5-2), xlibs-dev (>> 4.1), libesd0-dev, libz-dev, libarts-dev (>=4:2.2.0-final-3), liblircclient-dev, libogg-dev, libvorbis-dev
Standards-Version: 3.2.1
Package: libxine-dev
diff --git a/debian/rules b/debian/rules
index 4e5f25c16..2ce385614 100755
--- a/debian/rules
+++ b/debian/rules
@@ -79,6 +79,7 @@ binary-arch: build install
dh_makeshlibs
dh_installdeb
# dh_shlibdeps
+ chmod +x debian/shlibdeps.sh
debian/shlibdeps.sh libxine${major}
dh_gencontrol
dh_md5sums
diff --git a/debian/shlibdeps.sh b/debian/shlibdeps.sh
index c602cea8c..0f07ca3a8 100755
--- a/debian/shlibdeps.sh
+++ b/debian/shlibdeps.sh
@@ -27,5 +27,22 @@ for file in `echo $OPTIONAL $RECOMMENDED`; do
REQUIRED=`echo "$REQUIRED" | grep -v $file`
done
+
+# remove nonexisting files, warn in that case
+for file in $RECOMMENDED; do
+ if test ! -f "$file"; then
+ echo "WARNING: non-existing file \"$file\" in RECOMMENDED list"
+ RECOMMENDED=`echo "$var" | grep -v $file`
+ fi
+done
+for file in $OPTIONAL; do
+ if test ! -f "$file"; then
+ echo "WARNING: non-existing file \"$file\" in OPTIONAL list"
+ OPTIONAL=`echo "$var" | grep -v $file`
+ fi
+done
+
+
+
dpkg-shlibdeps -Tdebian/$1.substvars \
$REQUIRED -dRecommends $RECOMMENDED -dSuggests $OPTIONAL