summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/dh_xine56
-rw-r--r--debian/dh_xine.121
-rwxr-xr-xdebian/rules2
3 files changed, 79 insertions, 0 deletions
diff --git a/debian/dh_xine b/debian/dh_xine
new file mode 100644
index 000000000..93657a86c
--- /dev/null
+++ b/debian/dh_xine
@@ -0,0 +1,56 @@
+#! /usr/bin/perl -w
+
+=head1 NAME
+
+dh_xine - calculates xine-lib dependencies
+
+=cut
+
+use strict;
+use Debian::Debhelper::Dh_Lib;
+
+=head1 SYNOPSIS
+
+B<dh_xine> [S<I<debhelper options>>]
+
+=head1 DESCRIPTION
+
+dh_xine is a debhelper program that is responsible for generating the
+${xine-x:Depends} and ${xine-console:Depends} substitutions and adding them
+to substvars files.
+
+Each xine-lib front end is required to have one of these two substvars
+listed in its Depends line in debian/control. Using package names directly
+will, sooner or later, break.
+
+=head1 CONFORMS TO
+
+Debian policy, version 3.8.1
+
+=cut
+
+init ();
+
+my $version;
+
+foreach my $package (@{$dh{DOPACKAGES}}) {
+ my $tmp = tmpdir ($package);
+
+ delsubstvar($package, 'xine-x:Depends');
+ addsubstvar ($package, 'xine-x:Depends', 'libxine2-x');
+
+ delsubstvar($package, 'xine-console:Depends');
+ addsubstvar ($package, 'xine-console:Depends', 'libxine2-console');
+}
+
+=head1 SEE ALSO
+
+L<debhelper(7)>
+
+This program is not a part of debhelper.
+
+=head1 AUTHOR
+
+Darren Salt <linux@youmustbejoking.demon.co.uk>
+
+=cut
diff --git a/debian/dh_xine.1 b/debian/dh_xine.1
new file mode 100644
index 000000000..5116d750a
--- /dev/null
+++ b/debian/dh_xine.1
@@ -0,0 +1,21 @@
+.TH DH_XINE 1 "2009-03-25" "The xine project"
+.SH "NAME"
+dh_xine - calculates xine\-lib dependencies
+.SH "SYNOPSIS"
+\fBdh_xine\fR [\fIdebhelper\ options\fR]
+.SH "DESCRIPTION"
+dh_xine is a debhelper program that is responsible for generating the
+${xine\-x:Depends} and ${xine\-console:Depends} substitutions and adding them
+to substvars files.
+.PP
+Each xine-lib front end is required to have one of these two substvars
+listed in its Depends line in debian/control. Using package names directly
+will, sooner or later, break.
+.SH "CONFORMS TO"
+Debian policy, version 3.8.1
+.SH "SEE ALSO"
+\fIdebhelper\fR(7)
+.PP
+This program is not a part of debhelper.
+.SH "AUTHOR"
+Darren Salt <linux@youmustbejoking.demon.co.uk>
diff --git a/debian/rules b/debian/rules
index fffb497e5..8c7a7b377 100755
--- a/debian/rules
+++ b/debian/rules
@@ -144,6 +144,8 @@ binary-arch: build install
mv debian/tmp/usr/share/doc/xine-lib debian/tmp/usr/share/doc/libxine${major}
# build libxine${major} package by moving files from libxine-dev
dh_install --autodest --sourcedir=debian/tmp --list-missing
+ install -m755 debian/dh_xine debian/libxine-dev/usr/bin
+ dh_installman -plibxine-dev debian/dh_xine.1
dh_installdocs
dh_installchangelogs -k ChangeLog
dh_link